Firefox Relay Outage
Incident Report for Firefox Relay
Resolved
All issues have been resolved.
Posted Mar 10, 2022 - 23:44 UTC
Update
Firefox Relay is still experiencing a service disruption, but much of the experience has recovered. The Relay website and add-on are available and stable. Emails are now being forwarded to users without any delay. Emails that were delayed during the outage, have been delivered to users.

Enabling/disabling promotional email blocking feature for premium users is not available at this time.

Email sizes under 10MB can be processed by Relay, although the Relay UI indicates that email sizes must be under 150KB.
Posted Mar 10, 2022 - 22:40 UTC
Investigating
Relay is currently experiencing issues. Users might experience disruption in their experience including not being able to access Relay.com and forwarded emails being delayed. Our team is actively working to resolve the situation.
Posted Mar 10, 2022 - 18:54 UTC
This incident affected: relay.firefox.com.