Phone numbers cannot be registered
Incident Report for Firefox Relay
Resolved
This incident has now been resolved. Phone masking users should now be able to register phone numbers.
Posted Nov 29, 2022 - 17:06 UTC
Investigating
Relay Phone Masking users currently cannot register for a new phone number, this will primarily impact new phone masking users. We are aware of the issue, have identified a fix, and are working on it right now.
Posted Nov 29, 2022 - 15:09 UTC
This incident affected: relay.firefox.com.