Issue with upstream provider
Incident Report for Firefox Relay
Resolved
This incident has been resolved.
Posted Nov 16, 2021 - 18:44 UTC
Update
This issue has been resolved with our upstream provider and services have returned to normal operations.
Posted Nov 16, 2021 - 18:42 UTC
Investigating
We are currently investigating an issue with an upstream provider that is affecting our services at the moment.
Posted Nov 16, 2021 - 17:59 UTC
This incident affected: relay.firefox.com.