Phone Numbers cannot be registered
Incident Report for Firefox Relay
Resolved
This incident has been resolved.
Posted Oct 27, 2022 - 19:32 UTC
Identified
Relay Phone Masking users currently cannot register for a new phone number, this will primarily impact new phone masking users. We are aware of the issue, have identified a fix, and are working on it right now.
Posted Oct 27, 2022 - 16:10 UTC
Investigating
Relay Phone Masking users currently cannot register for a new phone number, this will primarily impact new phone masking users. We are aware of the issue, have identified a fix, and are working on it right now.
Posted Oct 27, 2022 - 16:10 UTC