Mail delivery taking longer than expected
Incident Report for Firefox Relay
Resolved
This incident has been resolved.
Posted Aug 30, 2022 - 16:10 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 29, 2022 - 22:29 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Aug 29, 2022 - 22:18 UTC
Investigating
We are currently investigating an issue that is causing email delivery to be delayed longer than expected.
Posted Aug 29, 2022 - 20:09 UTC
This incident affected: relay.firefox.com.